Congratulations! 😍 As a blog reader, get a 10% OFF on WP Frontend Delete Account PRO. Use coupon code WPFDA10OFF.

Himalayan Bank recently updated its payment API to v2. The Himalayan Bank WordPress plugin version 1.x. doesn’t work anymore. Please update the plugin to v2 if you still have version 1.x on your site.

If you’re new, check out the documentation on accepting payments via Himalayan Bank.

What’s new in v2?

While in version 1, the JSON request was sent to API, now it’s JOSE request which is probably more secure. The setup is comparatively very difficult to v1. You’ll need to generate the signing and encryption keys by yourself and provde them to bank. 😮

Version 2 in fact has significant changes. All the codes are rewritten and the plugin is more secure.

Changelog

== Changelog ==

= 2.2.1 - 02/22/2024 =
* Fix - Invalid product description when long product title

= 2.2.0 - 1/24/2024 =
* Tweak - Add Sodium Extension requirement notice
* Fix - PHP 8.2 deprecated messages
* Fix - JWT issue due to claim

= 2.1.0 - 01/29/2023 =
* Stable Version.

= 2.0.9 - 01/13/2023 =
* Fix - Redirect to HBL payment instead of on-site payment.

= 2.0.8 - 01/13/2023 =
* Fix - Various request args.

= 2.0.7 - 01/10/2023 =
* Fix - Access Token Issue & Proper Response

= 2.0.6 - 01/09/2023 =
* Fix - Case sensitive directory issue.

= 2.0.5 - 01/07/2023 =
* PHP 8.1 is required for composer dependencies.

= 2.0.4 - 01/08/2023 =
* Live Mode.

= 2.0.3 - 12/18/2022 =
* Fix - Amount mismatch.

= 2.0.2 - 12/18/2022 =
* Fix - Remove CC details from logs.
* Fix - Remove PHP 8.0 requirement, the plugin works on PHP 7.x as well.

= 2.0.1 - 12/17/2022 =
* Fix - Update payment status on success.

= 2.0.0 - 12/17/2022 =
* Update to new API
Introducing Himalayan Bank WooCommerce Plugin v2
Tagged on:         

Sanjeev Aryal

Don't bury your thoughts, put your vision into reality ~ Bob Marley.

5 thoughts on “Introducing Himalayan Bank WooCommerce Plugin v2

  • February 11, 2024 at 12:13 pm
    Permalink

    The plugin is not working. Gives this ERROR: Payment type not support

    Reply
  • May 17, 2023 at 11:29 am
    Permalink

    Invalid product description after cart item checkout..

    Reply
    • February 21, 2024 at 8:45 am
      Permalink

      It looks like a issue when there are multiple products in the cart. It’s noted down to fix. Thanks!

      Reply
  • March 27, 2023 at 8:32 am
    Permalink

    it is not working in Php 7 version

    Reply
    • March 27, 2023 at 8:35 am
      Permalink

      Yes, it’s correct that the latest version (2.1) plugin requires PHP 8.1 or higher.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *